phpMyAdmin по-русски
   О проекте  |  Скачать  |  Документация  |  Форум
  
Главная страница / Новости / phpMyAdmin /

Уведомление безопасности phpMyAdmin №5 2005

уведомление безопасности phpMyAdmin
Announcement-ID: PMASA-2005-5
Date: 2005-10-22
Updated: 2005-10-25 (уведомление от T.K.)

Сводка: (1) Локальный инклюдинг файлов (Local file inclusion) и (2) межсайтовый скриптинг (Cross-Site Scripting)

Описание:
Командой разработчиков было получено уведомление о безопасности от Стефана Эссера (sesser_at_hardened-php.net) по первой уязвимости (1). Также было получено уведомление о безопасности от Тобиаса Кляйна (tk_at_trapkit.de) по второй уязвимости (2).
(1): Из-за последовательности выполнения в коде, который получает параметры формы в отдельных скриптах, существовала возможность разработать специальную форму для атаки, которая бы переписывала параметры конфигурации.
(2): Некоторые скрипты были уязвимы для XSS атак: left.php, queryframe.php и server_databases.php.

Серьезность:
Команда разработчиков полагает, что данные уязвимости серьезные. Тем не менее, (1) первая уязвимость может использоваться только на системах, где PHP не запущен в безопасном режиме (до тех пор пока не будет преднамеренно открыта дыра включением в open_basedir некоторых путей, содержащих уязвимые данные).

Затронутые версии:
По всей видимости данной уязвимости подвержены все предыдущие версии.

Решение:
Обновить phpMyAdmin до 2.6.4-pl3 или новее

Ссылки:
Для (1): http://www.hardened-php.net/advisory_162005.73.html
Для (2): http://www.trapkit.de/advisories/TKADV2005-10-001.txt
Опубликовано: 2005-10-22