phpMyAdmin по-русски
   О проекте  |  Скачать  |  Документация  |  Форум
  
Главная страница / Новости / Open Source /

Разработчики PHP выступили с заявлением о прекращении поддержки PHP4 с 2008 года

Разработчики PHP форсируют переход на пятую ветку
Ранее мы уже писали об инициативе веб-проектов и хостинговых компаний по форсированной миграции с PHP4 на PHP5 - GoPHP5. Теперь с соответствующим заявлением выступили разработчики PHP.

Сегодня исполняется ровно три года с того момента, как был анонсирован PHP5. За эти три года многое было сделано по усовершенствованию PHP - пятая версия более быстрая, более устойчивая, более производительная. На горизонте уже маячит PHP6.

Сегодня команда разработчиков сегодня объявила о прекращении поддержки PHP4 после 2007-12-31. Тем не менее, разработчики обещают периодически исправлять обнаруженные критические уязвимости в безопасности вплоть до 2008-08-08. Тем кто использует PHP4 рекомендуется использовать оставшиеся 6 месяцев для того чтобы обеспечить совместимость приложений с PHP5.

Разработчики предлагают в помощь пользователям руководство по миграции с PHP4 к PHP5 (eng), а также руководства по миграции с PHP 5.0 к PHP 5.1 (eng) и с PHP 5.1 к PHP 5.2 (eng).
Опубликовано: 2007-07-13