phpMyAdmin по-русски
   О проекте  |  Скачать  |  Документация  |  Форум
  
Главная страница / Новости / phpMyAdmin /

Подготовлены экстренные выпуски phpMyAdmin версии 3.4.3.2 и 3.3.10.3

phpMyAdmin 3.4.3.2 и 3.3.10.3
Вышли экстренные выпуски phpMyAdmin версии 3.4.3.2 и 3.3.10.3.

Причиной экстренного выхода phpMyAdmin версии 3.4.3.2 и 3.3.10.3 послужили найденные 4 уязвимости уровня безопасности.

PMASA-2011-9
Атакующий должен создать подставную ссылку кликнув по которой осуществляется переход к скрипту таблицы печати phpMyAdmin; один из параметров ссылки является подставное имя таблицы (имя содержит JavaScript код).

PMASA-2011-10
С помощью подставного MIME-типа параметра трансформации, атакующий может произвести включение локального файла.

PMASA-2011-11
В коде параметра связанной схемы не используется необходимая проверка перед объединением с именем класса.

PMASA-2011-12
Была возможность изменения суперглобальных PHP (включая сессию, SESSION) используя часть кода авторизации Swekey. Так же под риском изменения находились локальные переменные функции Swekey. Ошибка идентична PMASA-2011-5.

Ссылки по теме:
Скачать phpMyAdmin версии 3.4.3.2
Опубликовано: 2011-07-25