phpMyAdmin по-русски
   О проекте  |  Скачать  |  Документация  |  Форум
  
Главная страница / Новости / phpMyAdmin /

Подготовлен первый релиз-кандидат phpMyAdmin 3.4.8

phpMyAdmin 3.4.8-rc1
Подготовлен первый релиз-кандидат phpMyAdmin 3.4.8, закрывающий найденные проблемы безопасности и ошибки в работе скрипта.

3.4.8.0 (в стадии разработки)
- bug #3425230 [интерфейс] Лишнее разбиение данных типа ENUM по пробелу.
- bug #3426840 [интерфейс] Неверное разбиение данных типа ENUM/SET в редакторе значений при наличии в них запятых.
- bug #3427256 [интерфейс] Отсутствие ссылок для отображение/очистки представлений и таблиц.
- bug #3430377 [интерфейс] Удаленные результаты поиска остаются видимыми.
- bug #3428627 [импорт] При импорте формата ODS игнорируются лимиты выделяемой памяти и времени выполнения скрипта.
- bug #3426836 [интерфейс] Видимые разделители столбцов.
- bug #3428065 [парсер] Значение TRUE не распознается парсером.
+ patch #3433770 [конфигурация] Возможность настроить местоположение php-gettext.
- patch #3430291 [импорт] Исправление конфликтов при некоторых настройках open_basedir.
- bug #3431427 [отображение] Не работает установка NULL для выпадающих результатов.
- patch #3428764 [редакция] Быстрое редактирование при мульти-серверной конфигурации.
- patch #3437354 [ядро] Замечание о переводе массива в строку в PHP 5.4.
- [интерфейс] При включенной директиве ShowTooltipAliasTB, представления (VIEW) неверно выводятся как имя представления в основной панели структуры БД.
- bug #3439292 [ядро] Ошибка синхронизации поля с именем соответствующим ключевому слову.
- bug #3425156 [интерфейс] Добавление столбца после его удаления.
- [интерфейс] Предупреждать отображение пароля в выводе phpinfo().
- bug #3441572 [интерфейс] Сообщение 'новейшая версия phpMyAdmin' не отображается в IE8.
- bug #3407235 [интерфейс] Ввод ключа через окно просмотра, не сбрасывает значение NULL.
- [безопасность] Внутренняя XSS уязвимость имен баз данных (Синхронизация), смотрите PMASA-2011-18.
- [безопасность] Внутренняя XSS уязвимость имен баз данных (Операции/переименование), смотрите PMASA-2011-18.
- [безопасность] Внутренняя XSS уязвимость типов столбцов (Создание индекса), смотрите PMASA-2011-18.
- [безопасность] Внутренняя XSS уязвимость типов столбцов (Поиск таблицы), смотрите PMASA-2011-18.
- [безопасность] Внутренняя XSS уязвимость неверном запросе (обзор таблицы), смотрите PMASA-2011-18.

Ссылки по теме:
Скачать phpMyAdmin 3.4.8-rc1
Опубликовано: 2011-12-01